tnblog
首页

使用VS Code开发Python

21人阅读 2019/2/9 17:41 评论:0 收藏
分类: Python


Vs Code开发Python可以很好的支持代码调试、智能提示、代码对齐等


1:下载VS Code

https://code.visualstudio.com/Download

vs code是绿色软件下载后直接解压即可运行不需要在进行安装

vs code同时也支持windows,linux,mac等,而且具有丰富的插件支持


2:给VS Code安装好Python插件

在插件里边搜索python然后点击安装即可(我这里以前已经安装过了)

3:安装好Python插件后就可以在vs code中打开python文件进行开发与调试

因为vs code其实主要是一个文件编辑器,python需要在外面新建好,然后打开文件夹即可

vs code会自动把文件夹的内容加入进来

按f5即可运行


如何在VS Code配置Python的版本

如果我们系统中装了多个python版本如何在vs code中配置合适的版本呢

比如系统中有两个Python版本,Vs Code中默认运行的是2.7版本

如果我们输出中文,就会出现乱码

现在我们进行python版本的配置

1:点击:  文件-->首选项-->设置


就会多一个文件User Settings

2:然后点击Python Configuration,找到pythonPath

点击左边的编辑,就会出现在右边进行修改

然后把这个地址修改成,3.6版本下面的

保存一下即可生效


为了验证是否成功重新运行输出一下即可

或者我们输出inp看到的智能提示也知道成功配置到3.6版本了




请先登录

{{item.title}}

{{item.content}}
不能简单的解决问题,那是设计与做法有问题
博主搜索
文章类别
CSS 5篇
云服务 2篇
Git 4篇
.NET 29篇
Android 0篇
软件架构 4篇
.NET Core 15篇
.NET MVC 3篇
英语 3篇
随笔 3篇
Bootstrap 1篇
Redis 12篇
编辑器 2篇
Js相关 6篇
Layui 2篇
Oracle 7篇
Python 2篇
数据库 2篇
EF 2篇
微信 2篇
前端 1篇
消息队列 1篇
最新文章
为什么要使用webapi而不直接使用controller
net core发布到IIS常见错误
net core依赖注入
NET CORE配置EF连接字符串
Net Core使用依赖注入来装载EF的上下文对象
下载net core
Sqlerver添加用户与授权
net core中使用url编码与解码操作
net core启动报错Unable to configure HTTPS endpoint. No server certificate was specified
.net core使用response
ef6动态添加条件
最新评价
{{item.ArticleTitle}}
{{item.BlogName}} : {{item.Content}}