tnblog
首页

python安装pip以及使用pip安装requests等模块

357人阅读 2018/12/30 22:14 评论:0 收藏
分类: Python


pip很简单的介绍

pip 是一个现代的,通用的 Python 包管理工具。提供了对 Python 包的查找、下载、安装、卸载的功能。



如果想使用pip安装模块就需要先安装pip


1:下载pip

下载地址:https://pypi.python.org/pypi/pip#downloads



2、下载完成后,解压到一个文件夹,用CMD控制台进入解压目录,输入:

python setup.py install

安装的时候有可能还会出现如下错误,setuptools这个模块默认也没有被安装



3、安装setuptools模块

下载地址:https://pypi.org/project/setuptools/


下载后进行解压,然后在解压的目录执行:python setup.py install即可安装成功


4、然后执行pip安装命令

   python setup.py install


安装成功后就可以在python的目录执行pip命令安装需要的模块

使用pip命令安装requests模块:pip install requests 

使用pip命令安装pymssql模块:pip install pymssql


有可能还是不行

这可能是因为电脑中安装了两个python的版本


执行的上述命令都有可能是安装到另外一个版本里边,例如我这里安装了2.7与3.6版本,本来是想把pip安装到3.6版本的

但是却安装到2.7版本了,这是因为我系统默认执行python命令就是2.7版本下的

所以如果想要默认执行的python版本是3.6也很简单,在2.7版本中把python名字修改一下就好了,

例如这里把2.7版本python名称修改成python2。



默认执行python的时候就是3.6版本了(当然3.6版本还是需要配置一下环境变量)






请先登录

{{item.title}}

{{item.content}}
不能简单的解决问题,那是设计与做法有问题
博主搜索
文章类别
CSS 5篇
云服务 2篇
Git 4篇
.NET 29篇
Android 0篇
软件架构 4篇
.NET Core 15篇
.NET MVC 3篇
英语 3篇
随笔 3篇
Bootstrap 1篇
Redis 12篇
编辑器 2篇
Js相关 6篇
Layui 2篇
Oracle 7篇
Python 2篇
数据库 2篇
EF 2篇
微信 2篇
前端 1篇
消息队列 1篇
最新文章
为什么要使用webapi而不直接使用controller
net core发布到IIS常见错误
net core依赖注入
NET CORE配置EF连接字符串
Net Core使用依赖注入来装载EF的上下文对象
下载net core
Sqlerver添加用户与授权
net core中使用url编码与解码操作
net core启动报错Unable to configure HTTPS endpoint. No server certificate was specified
.net core使用response
ef6动态添加条件
最新评价
{{item.ArticleTitle}}
{{item.BlogName}} : {{item.Content}}